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About BlueGriffon and this document

1. About BlueGriffon and this document

OPEN POWERED BY

2010 M nsi'exp(orateur
FORUM Innovation Award m 0 Z I a i 2011 Top 100

BlueGriffon is a Wysiwyg editor based on Gecko, the rendering engine of Firefox.
It's a product of Disruptive Innovations SAS, a french software company based
in Saint-Germain en Laye, France, and the direct successor to another famous
Wysiwyg editor released by Disruptive Innovations, Nvu.

BlueGriffon does not share any code with Nvu and was rewritten from scratch to
match Firefox's evolution and new feature set.

It is available for free from http://bluegriffon.org and is released under the three
licences MPL, GPL and LGPL.

This manual is using screenshots made on Mac OS X only because it is our
primary coding platform. The Windows and Linux versions of the application are
very similar, the codebase of BlueGriffon being shared entirely across platforms.
You may notice light differences like the position of Ok and Cancel buttons but
nothing more.

This manual was of course entirely written using BlueGriffon itself. Please note it
is not a HTML5 or CSS2/CSS3 tutorial but a User's Manual.

This manual is not free or Open Source material and it is sold to support

the fact the application BlueGriffon is and will remain free of charge. You
are not allowed to redistribute this Manual.

Features new in version 1.7 are tagged [NEWIRNVANZ!.
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Installing BlueGriffon

3. Installing BlueGriffon

First, download the BlueGriffon package corresponding to your machine and
operating system from http://bluegriffon.org/pages/Download . BlueGriffon is
available for the following platforms:

* Windows (XP, 7, 8)
o you can download an installer or a ZIP of the full BlueGriffon
package if your network does not let you download a *.exe
* Mac OS X, Intel, 32 and 64 bits
o this is a Universal Build for Intel 32 and 64 bits processors; PPC is
not supported.
* Ubuntu 32bits and 64bits(12.04 and 13.04)
> you can download a *.tar.bz2 of the full BlueGriffon package

For other platforms/operating systems, we don't provide official builds. You can
still build BlueGriffon yourself following these instructions.

m you may have to delete your BlueGriffon profile if you installed
preview versions of the editor or if you have trouble changing the language of
the interface. You will have to re-install your add-ons after that.

« on Mac OS X: delete ~/Library/Application\ Support/

BlueGriffon

* on Windows XP: delete c:\Documents and
Settings\yourlogin\Application Data\Disruptive
Innovations SARL

e on Windows 7 delete

c:\Users\yourlogin\AppData\Roaming\Disruptive
Innovations SARL
* on Linux: delete ~/.disruptive\ innovations\ sarl

3.1. Windows

Just double-click on the installer's exe if you chose to download the installer.
Follow the steps on screen.

If you downloaded the zip package, unzip it using the Windows Explorer or a third-

party tool. The executable is the bluegriffon.exe file in the directory the unzip
process creates.
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Mac OS X

3.2. Mac OS X

Open the dmg package you just downloded double-clicking on it. It contains the
BlueGriffon application. Just copy it to your /Applications folder in the Finder.
You can then eject the package.

3.3. Ubuntu
Open a Terminal Window and go to the directory you want to contain your
BlueGriffon directory. Run the command bzip2 -dc <package file> | tar

xf - . That will create a bluegriffon directory.

To run BlueGriffon, launch the bluegriffon file in the directory you created
through the manual procedure just above.
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First launch

4. First launch

untitled - BlueGriffon

[ — S

foed

oo 5w

Get add-onst (oo ) @ &

If the language of your Operating System is natively supported by

BlueGriffon (Czech, Dutch, English, Finnish, French, Galician, German, Hebrew,
Hungarian, ltalian, Japanese, Korean, Polish, Serbian, Simplified Chinese,
Slovenian, Spanish, Swedish and Traditional Chinese), the application should
automatically use it.

See also: The Advanced preferences panel

On Windows and Linux, the menubar is included in that window. The Mac OS X
menubar shows:

BlueGriffon File Edit View Insert Format Table Panels Tools Help

The windows is divided as follows, from top to bottom:

the menubar (top of screen on Mac OS X)

the main toolbar

the format toolbars

the tab box

the editing viewport with its horizontal and vertical rulers and, on the right-
hand side, a container for dockable panels

the wisiwyg/source switch

the structure bar

the status/add-ons bar

aobh 0N~
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Toolbar customization

Additionally, BlueGriffon can show at launch a Tip of the Day window:

BlueGriffon tips

Did you know that...

...attributes can be added to any
element?

Open “Panels > DOM Explorer”. In wysiwyg view
click in the element, select use the Attributes tab
and click the plus sign.

« = [/ Show tips at startup

Use the arrow buttons to browse the available tips. You can hide that window at
startup unchecking the Show tips at startup checkbox . To view a Tip of the Day
at any time, use the Help > Tip of the Day menu entry.

4.1. Toolbar customization

First thing to know here, you can customize BlueGriffon toolbars. Right-click on a
toolbar and select Customize . It will open a panel like the following one:

You can add or remove items by dragging to or from the toolbars.

Separator Flexible Space Space

Show: | ! Ci ] Use Small Icons (Add NewTDolbarj ( Restore Default Setj
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Zooming

You can then drag an toolbar item from the panel to the toolbar(s), drag a toolbar
item from a toolbar back to the panel, move a toolbar item inside toolbar(s).
Toolbar items from the main toolbar(s) and toolbar items from the format toolbar(s)
belong to two different toolbar spaces.

You can create a new toolbar using the (Add New Toolbar| button. You'll be
prompted for a unique name for that new toolbar. To restore the default set of
toolbars, use the (Restore Default Set| button.

some add-ons to BlueGriffon can offer, at first launch after installation
of the add-on, to install a new toolbar item.

4.2. Zooming

You can zoom in or out the Wysiwyg and Source views of BlueGriffon using the
zoom controls at the bottom right of the main window:

30%
50%
67%
803
a0%
110%
120%
133%
150%
170%
200%
240%
3I00%

Y
-

i
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The Preferences window

5. The Preferences window

Before we start working with Web pages, let's have a look at the Preferences
window. On Mac, you can open it through the Preferences menu item in the
BlueGriffon menu. On Windows and Linux, that menu item lives under the Tools
menu.

5.1. The General preferences panel

Ceneral

= O DA & & X

General Filé Documents Source Styles Updates Advanced Keyboard Shortcuts 05 X

Position of Tabs

O Left (*) Center O Right

Structure bar
# show ID # show classes
E Show ARIA role [ show language
Spelichecking

] Enable real-time spelichecking

Number of suggestions: 10 '-:-'

The General panel offers the following controls:

» change the position of the tabs above the editing viewport: left, center or
right position. We prefer "center", Windows and Linux users are usually
more used to "left".

+ specify what BlueGriffon will shows for each HTML element in the structure
bar: its ID if present, its classes if any, its ARIA role if any, its human
language if set.

* enable or disable real-time spell-checking and the number of suggestions
to show when the spellchecker detects a potential error. When this feature
is enabled, words detected by the spell-checker are underlined in red on
the fly in the editing window. It's not possible at this time to change the
color of that outline.

See also: Install a spell-check dictionary
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The File preferences panel

The real-time spell-checker can impact performance when you

switch back from Source view to Wysiwyg view because a full spell-check is
performed on the whole document. If you experience long delays performing
that action on a long document with rich textual contents and find it annoying,
disabling the real-time spell-checker should help. You can still spell-check
manually the whole document at any time.

5.2. The File preferences panel

File

General File Documents Source Styles Updates Advanced Keyboard Shortcuts 05 X

File extensions for new files

For HTML documents:  html

for XHTML documents:  xhtml

(leave empty for default extension)
Recent files

Maximum number of files in recent history: 1013 files

E Restore last session's tabs

The File panel offers the following controls:

+ specify the default extension you want to use for HTML and XHTML files.
Empty fields will default to platform's defaults for such files.

* change the number of files BlueGriffon will remember in its File > Recent
Files menu

* restore or don't restore the last editing session when you start BlueGriffon.
This is enabled by default, so BlueGriffon will launch opening the
document you edited last time you used it, a great time-saver.
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The Documents preferences panel

5.3. The Documents preferences panel

Documents

General File Documents Source Styles Updates Advanced Keyboard Shortcuts 05X

Author

Author's name:

Zoom

Default zoom factor { 100 %

Editing features
¥ Create a backup before saving a file (*.bak}
E‘ Return key in a paragraph always creates a new paragraph
) show HTML comments
(! Show PHP instructions
2‘ Show other Processing Instructions

Copy/paste management of hyperlinks

(O Preserve relative URLs (=) Make all URLs absolute

The Documents panel offers the following controls:

+ set the Author's name that will be added to all new blank documents
through a <meta> element. Please note that name does not directly
appear in the document when you browse it, but is only contained in the
document's metadata.

 set the default zoom factor when you open an existing document or create
a new one

+ create a backup of all saved documents using the *.bak file extension

» change how BlueGriffon behaves when you press the CR key inside or at
the end of a paragraph: create a new paragraph or switch back to normal
text. The default is to create a paragraph.

* show HTML comments in the Wysiwyg view

» show PHP instructions in the Wysiwyg view

» show other Processing Instructions in the Wysiwyg view

» define how hyperlinks should be copied and paste, preserving relative
URLs or always turning them into absolute URLs
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The Source preferences panel

5.4. The Source preferences panel

Source

General Filé Documents Source Styles Updates Advanced Keyboard Shortcuts 0S5 X

Source view

o

Theme: | light

Serialization
Output the following characters as entities:

Only & < > and no-break space

|

E Force Unix-style carriage returns (LF)
EAuto—inde nt

EWrap leng lines
when lines go beyond column 80 ':'

@ Don't wrap documents in the following languages:

(ex: ja-JP, zh-TW)

The Source panel offers the following controls:

set the default theme for the Source View

See also: Set the current Source View's theme

» specify that you want your documents to always be saved with Unix-
style carriage returns (LF) instead of the platform-dependant ones. That

preference is turned OFF by default.

» set how the special characters are output to the Source View and to file
» enable or disable the auto-formatting of the source code in the Source

View and in files

+ set which languages should never wrap text (useful for a lot of Asian

languages)
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The Styles preferences panel

5.5. The Styles preferences panel

Styles

=m0 3 D48 & X

General File Documents Source Styles Updates Advanced Keyboard Shortcuts 05X

CSS Palicy
O Automatic
Enter a prefix for IDs and classes

() Manual

CSS Colors

gAlways try to output CS5 3 color names

O prefer rgb(r,g,b) values (%) Prefer #rrvwbb values

Browser support
| Gecko-based browsers (Firefox, Camino, ...}
gWebKit—b:lsed browsers (Safari, Chrome, ...}
gOpera

¥ Internet Explarer

The Styles panel offers the following controls:

» set how the CSS Properties panel should deal with missing IDs and
classes when you assign a style to an element. With the automatic CSS
Policy, BlueGriffon will assign a random ID or class to the element if
needed; you can give a prefix that will used in these cases. With the
manual CSS Policy, the CSS Properties panel will always ask you for an
ID or class when needed.

IN[o)H The default value when you launch BlueGriffon for the first

time is 'manual'. Switch to the automatic CSS Policy if you have no
CSS knowledge.

set the browser support for the CSS output: BlueGriffon always outputs
experimental styles (for instance the -moz-1linear-gradient () value
of the background-image property) for Gecko. You can tell it to also
output styles for the other main browsers of the market. BlueGriffon will
then do its best to translate the experimental values into the corresponding
values for these browsers. Please note it's not always feasible, a known
case where it's impossible being the original WebKit syntax for gradients.

I\[ICHM [t is recommended to leave this set of preferences
unchanged if you have no CSS knowledge.
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The Updates preferences panel

5.6. The Updates preferences panel

Updates

General File Documents Source Styles Updates Advanced Keyboard Shortcuts OS5 X

E Check for BlueGriffon updates
® Every time BlueGriffon is launched

:':* Mot more than once per day

:':* Manually
- - . -
[ Check now | Privacy policy

i

The Updates preferences panel allows to control how BlueGriffon looks for

updates. You can also verify immediately if an update is available clicking on the
"Check now" button.

When BlueGriffon looks for an update, it sends one single request to our server to
retrieve a trivial XML document containing two things:

1. the version number of the last available version of BlueGriffon,
2. an optional message to users.

See also: Be sure we don't care less about privacy than you do. If you

wonder what we do with the data sent when BlueGriffon pings our web site to
look for a new version, please read this document.
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The Advanced preferences panel

5.7. The Advanced preferences panel

Advanced

—— =* o] 7 [ ]| ]
s ) e ‘ﬁ = *ﬁ J
General File Documents Source Styles Updates Advanced Keyboard Shortcuts 0S X

Network

Configure BlueGriffon's network settings (" Parameters... )

BlueCGriffon's User Interface

) Try to use Operating System's locale
(2) use installed locale

zh-TW (Chinese, Taiwan) ']
zh-CN (Chinese, China)

sv-5E (Swedish, Sweden) i
sr {Serbian) v

(use language )

External Preview

- 7 P
( Reset external browser's settings

Advanced Configuration

( Configuration Editor 3

The Advanced preferences panel offers the following controls:

+ set the application's network settings (see below)
+ set the language of the User Interface of BlueGriffon
o use, as far as it's possible, the language of the operating system
of your machine; that will fallback to english if that language is not
available
o or select a language in a list of available languages for
BlueGriffon's Ul
» reset the browser settings of the application. If you click that button,
BlueGriffon will "forget" all choices you made in the past to reach an
external URL from within BlueGriffon and you'll be able to select again a
web browsing application.
* browse and set directly the preferences of the application

setting directly application's preferences should be reserved to

advanced users... Don't do that if you're not sure of what you're doing, it could
severely harm your BlueGriffon profile...

5.7.1. Network settings

The network settings panel allows you to control how BlueGriffon accesses the
Internet. This dialog is totally similar to Firefox's.
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The Keyboard Shortcuts preferences panel

Advanced
—
Configure Proxies to Access the Internet
Genera
_ INo proxy
Nety ( _ | Auto-detect proxy settings for this network
Ca : IUse system proxy settings :
( _ )Manual proxy configuration:
Blue
HTTP Proxy: Port: 0|
Use this proxy server for all protocols
SSL Proxy: Port: 0: N
FTP Proxy: Port: 0|
SOCKS Host: Port: 0| |
SOCKS v4 (=)SOCKS v5 :
Extd No Proxy for: localhost, 127.0.0.1
Example: .mozilla.org, .net.nz, 192.168.1.0/24 L
( _ | Automatic proxy configuration URL: L
Adv Reload
| Cancel | | oK | L
— | ——

5.8. The Keyboard Shortcuts preferences panel

Keyboard Shortcuts

General Flle Documents Source Styles Updates Advanced Keyboard Shortcuts 05 X

Command Shortcut
Menubar )
File
New ®T
New wizard
Recent files

One-click Templates

New Window EN
Open {30
Open File ®0
Save xS
Save As_.. {+3E5
Close current tab BW
Quit #£0
Edit "
Wiew b

This feature is pretty unique in the Mozilla-based world. It allows to redefine or
define all keyboard shortcuts for all menu entries, and all main and format toolbar
items. To define or redefine the shortcut for a given menu entry or a toolbar item,
just double-click on it. It will open the following dialog:
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The OS X preferences panel

Label: Mew
Shortcut: HN
| Delete shortcut | [ Cancel | | Apply |

Just type the desired shortcut on your keyboard and it will appear directly in the
Shortcut field of that window. To delete an existing shortcut, press the "Delete

shortcut" button. To apply a change, press the "Apply" button. The cancel button
cancels the change/definition action.

5.9. The OS X preferences panel

= e 0 A8 8 & X

General File Documents Source Styles Updates Advanced Keyboard Shortcuts 05 X

@ Show number of modified documents in 05 X dock

This preferences panel is obviously available only on Mac OS X. It allows to show
or not the number of currently modified and unsaved documents inside the OS X
dock icon of BlueGriffon.

@

Please also note that a BlueGriffon window containing a modified and unsaved
document has a special close button with a black dot inside:
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Add-ons and Language Packs

6. Add-ons and Language Packs

BlueGriffon is available free of charge. That is possible because we sell add-ons
(also called extensions) to BlueGriffon to enhance your editing experience. These
add-ons are available from http://bluegriffon.com .

The Add-ons Manager allows you to manage your add-ons, language packs and
themes for BlueGriffon. It is reachable through the Tools > Add-ons menu entry.

Add-ons Manager

| 2 | 3 '| 'Q Search all add-ons

CSS Stylesheet Editor 0.1.3.1

o -
STUB for CSS Stylesheet Pro Editor for BlueGri... More Disable | | Remove

E& Extensions
Z EyeDropper 0.1.3.1

;/j: Appearance STUB for EyeDropper for BlueGriffon  More _I?l_sa_blt_a | RE_n'1_t1VG_.
a8 i —  FontSquirrel Manager 1.0.1.4
Plugins '
i Plug : T
FontSquirrel Manager for BlueGriffon More Disable | Rem9£|
@ Languages |ﬁ Fullscreen 0.1.3.1
ko STUB for Fullscreen for BlueGriffon More | Disable | | Remove

Google Font Directory Manager 1.0.1.4

Google Font Directory Manager for BlueGriffon More | Disable | | Remove

To install an add-on, click on the wheel button at the top and select "Install add-on
from file".

See also: the detailed Installation Instructions for installing purchased or free
add-ons

Selecting "Languages” in the window above, you can see a list of all the installed
language packs. You can safely remove the ones you will never use to save disk
space and improve BlueGriffon startup time.

m it is not recommended to delete or disable the English (US) locale.

when you purchase an add-on from http://bluegriffon.com, it usually

comes as a ZIP file containing a License document and three XPI files (one for
OS X, one for Windows and one for Linux) or one single XPI for all platforms.
It is highly recommended to store that ZIP or XPI file somewhere just in case
you have to reinstall BlueGriffon or delete a corrupted profile.
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Add-ons and Language Packs

\e)-Hl an add-on purchase is only valid for one single user on one single
machine.

To install a language pack from a file, install it as an add-on (see just above).
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Manipulating documents

7. Manipulating documents

7.1. Create a new document
There are three different ways of creating a new document:

1. using the File > New menu entry, the corresponding keyboard shorcut (in
english, Cmd-t on Mac and Ctrl-t on Windows and Linux) or a click on the

New button of the main toolbar .~

That will create in a new tab a document conformant to your last choice of
document (html4, xhtml1, ...)

2. using the dropdown menu of the New button of the main toolbar or the
corresponding keyboard shortcut (in english, Cmd-shift-n on Mac and Ctrl-
shift-n on Windows and Linux)

That will allow you to create a document of the desired HTML dialect, in a
new tab.

What kind of document do you want to create?
Document type
OHTML4 OXHTML T O XHTML 1.1 ) HTML 5 (O XHTML 5

Transitiona Strict

.~ N
Language: L Select a language |

Character set: | Unicode (UTF-8) ﬂ

Text direction: ®) Unspecified () Left to right O Right to left

\.

Similar to current document L Cancel ) L OK 9

You can also specify the human language, the character set and the
writing direction of your new document. To copy those settings from the
currently edited document, use the [ Similar to current document | button.

It's not possible any more to select a character set with XHTML5
documents since that character set must be UTF-8, per spec.
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The New Document Wizard

It's now possible to create XHTML 1.1 documents.

3. using the File > New wizard menu entry

Unless you have strong HTML knowledge and really require a specific
dialect of html, we recommend you use XHTML 5.

To create an new empty window, use the File > New Window menu entry or the
corresponding shortcut (in english, Cmd-n on Mac and Ctrl-n on Windows and
Linux).

7.1.1. The New Document Wizard
The New Document Wizard, reachable through the File > New wizard menu
entry, allows you to create a richer document than just a blank document. It opens

the following wizard dialog:

New Document Wizard

Document type

What kind of document do you want to create?

Document language

®HTML4 O XHTML 1 OXHTML 1.1 (O HTML S (O XHTML 5

Document type

() P e
\%) Transitional [_) strict

£ = . X - - - A
[ Cancel ) Co Back [ Continue )

That first page of the wizard allows you to set the dialect of html you want to use.
Any choice made in that page will be persistent across sessions. Once this is
done, click on the button to switch to the second page of the wizard.
You can go back to any page of the wizard at any time if the button is
not disabled.
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The New Document Wizard

New Document Wizard

General document properties

Title:

Author:

Description:

Keywords:

Language: Select a language
Character set: Unicode (UTF-8)

Text direction: (*Unspecified () Left to right (_) Right to left

Cancel Go Back Continue

That page allows you to set the main metadata of the document:

Title, Author, Description and Keywords. The predefined value of the
Author field will always be the one set in the Preferences window.

* The main language of the document

» The character set of the document

» The main writing direction of the document.

The character set selection is disabled for XHTML5 documents since it must be
UTF-8 per spec.

Selecting a language will open the following dialog:
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The New Document Wizard

Current language is:

Languages:
Abkhazian [ab]
Afrikaans [af]
Albanian [sg]

Ambharic [am)]

Arabic [ar]
Arahic/Algeria [ar-dz]
Arabic/Bahrain [ar-bh]
Arahic/Egypt [ar-eg]

Others: e.g.: en-bz, ar-jo

| Cancel | OK

Select a language in the list or type its code and hit the button.

New Document Wizard

Colors and backgrounds

|_| Use custom colors:

Background:

i
/| Normal text
Text: @) ,
| Links
Links: @),
_ =, Active links
Active Links: @),
Visited Links: ':/-\:' Visited links
,

-

/| Underline links

@ Make the above my default settings

| Cancel | | GoBack | | Continue |

The third page of the New Document Wizard allows you to set the default colors
of the document: its background color, the foreground (text) color and the color of
links. All choices made here will be applied to the document through CSS styles
contained in a stylesheet embedded into the new document.

26/77



The New Document Wizard

New Document Wizard

Document background

Background Image: [%
Tile: | None + |
Scrolling: | With the page > |

Horiz: 50% Vert: 50%

Position:

| Cancel | | GoBack | | Continue |

You can apply a background image to the whole document through the new
page. You can select a background image, define how it will be repeated over the
document, say if it should scroll with the document or remain fixed and finally finely
set its position in the document's background.

New Document Wizard

Page layouts

|| Apply a predefined C55 layout

Width: | Full width = Sidebar: | Left 160px

+

Ig’l Include 'lorem ipsum’ dummy content

| Cancel | | GoBack | | Done |

The last page of the wizard is probably the most powerful one: it lets you apply a
grid layout based on the YUIZ2 library from Yahoo!. You can define the width of the
main content area of your document and say if it should contain a sidebar and in
that case, where (left or right). Once this is done, you can click on the button
to add grid divisions of your content area. You can delete an already created grid
division selecting it in the list and clicking on the @ button.
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Open an existing file

The last checkbox of the document allows to populate your empty document with
dummy content. That can be very useful to have a more visually editable layout of
your new document. Just select the newly created dummy content and replace it
by your own to write your document.

a grid-based document created by the wizard is entirely standalone.

All necessary styles and structure are fully embedded into your document and
your document does not rely on any external resource. YUI2 grids require no
JavaScript code at all.

Click on the button to finally create the new document according to all your
design choices.

7.2. Open an existing file

Top open an existing html/xhtml/html5 file into a new tab, you can use the File >
Open File... menu entry or use the corresponding shortcut (in english, Cmd-o on
Mac and Ctrl-o on Windows and Linux). See below for more options.

7.3. Open an existing document

To open an existing html/xhtml/htmI5 document, you can use the File > Open
menu entry, use the corresponding shortcut (in english, Cmd-Shift-o on Mac and

Ctrl-Shift-o on Windows and Linux) or click on the Open toolbar button wfi .

Enter the web location (URL) of the file /template, or choose a local one:

Choose File...

Create ina (*/Tab [_'Window

Cancel 0K

If the file you want to open is a remote resource reachable through HTTP, just type
the URL in the text field in that window. If it is a local file, click on the | Choose
File... button to select it. Accepted extensions are *.html and * . xhtml.

Opening the dropdown menu attached to the toolbar button will allow you
to say if you want to open the document in a new tab or a new window. By default,
documents are always opened in a new tab.

The OS native filepicker that shows when you click on the [Choose file... ] button
now lets you open *.php files if you select "PHP files" in its dropdown menu.
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Save an edited document

Please note the support for editing PHP files is experimental and

will never be able to deal with all arbitrary PHP files. In particular, a PHP file that
is not a conformant HTML document at all could lead to strange results when
opened by BlueGriffon.

7.4. Save an edited document

You can save an edited document through the common File > Save or the File
> Save As... menu entries. There is no auto-save feature in BlueGriffon 1.5.
BlueGriffon can create a backup of your file when you save the document.

See also: the OS X Preferences Panel if you use a Mac.

it is very highly recommended to use the *.html extension for

HTML4 and html5 (HTML serialization) files, and the *.xhtml extension for
XHTML1 and html5 (XML serialization). Using the *.html extension for local
XHTML1 and XHTMLS5 files could lead to XML syntax errors in the Source view
or saving the file...

if you need to force carriage returns to be LF independently of your

current platform's common practice because for instance of a version control
system, see the Source Preferences panel.

7.5. Edit the Properties

To edit the general properties of a document, use the Format > Page Properties
menu entry:

Location: [New page, not saved yet]
Last Modified: [Unknown)]

Title:

Author:

Description:

Keywords:

Language: [ Text Language 4

.
¥

|
r

Character 5et: | Unicode (UTF-8)

Fi

Text Direction: (*) Unspecified ) From Left to Right [_)From Right to Left

-\.
3

i i Y I.-"
§ Cancel 9 C Ok

29/77



Document tabs

The dialog shows you the URL of the document if it already has one, and and the
date and time it was last modified. It allows you to set the title and other metadata
for the document, including its main language and writing script direction.

You can also now change the character set of your document. The change in the
file will happen next time you save the document.

7.6. Document tabs
Document tabs reflect the title of the document (or a predefined name like

"Untitled" if no title is defined yet), it's favicon if there's one and the status (saved
on unsaved) of the document.

BlueGriffen User's Man... .| sans titre | FZ] CNN.com International ...

In the screenshot just above, text in the leftmost tab is outlined in red, indicating
the document is modified and unsaved. The tab in the middle contains a document
with an empty or non-existent <title> element. The last one shows the home
page of CNN opened by BlueGriffon, and editable.

A tooltip is available on each tab and shows the dialect of HTML used by the
document (HTML4, XHTMLA1, html5, xhtml5).

There are three ways to close a tab: you can use the corresponding File > Close
current tab menu entry, you can use the associated shortcut (in english, Cmd-w
on Mac and Ctrl-w on Windows and Linux) or you can click on the close button
that will appear in the tab itself if your mouse hover over the tab :

. untitled | % | |

If the document is modified and unsaved, BlueGriffon will prompt for an optional
document title is no title is already present in the document before offering to save
the document, discard the changes or cancel the action.

The position of tabs in the window (left, center or right) can be changed through
the Preferences.

A contextual menu is available on tabs:
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External files

i Man... l
— Close Tab =
Close Other Tahs

id  Revert t

You can close the selected tab, close all tabs but the selected one, and revert
the document (i.e. abandon the current modifications and revert to the last saved
version of the document).

7.7. External files

If you changes outside of BlueGriffon an external file, for instance a stylesheet or
an image file, referenced by a document currently edited in BlueGriffon, the editor
will warn you, will reload that file and reapply it to that document.

A file was changed on disk

File prefsWindow-1.png changed on disk, BlueGriffon
must reload it

["] don't show this alert again

OK

If you check the chekbox before hitting the button, BlueGriffon will not show
this dialog again.
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8. Select elements in the document

8.1. The All-Tags mode

The View > All Tags menu entry will enable or disable the All Tags mode in
the Wysiwyg view of your document. The All Tags mode shows almost all the
elements tags of your document in your Wysiwyg view. You can click or double-
click on tags to select or edit them (if a specific dialog exists for that tag).
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site to look for a new version, read -jéj- this document.

@) L@ @& The Advanced preferences panel

a few elements, notably the img element, do not show a tag in this

mode. This is a complex bug related to empty replaced elements we are working
on.

8.2. Reaching the target of a link

If the caret is placed inside a local link, i.e. a link targeting an element inside the
current document, you can right-click and select the Select the target of the link
menu entry to move the caret automatically to that element. You can also use the
Edit > Select the target of the link menu entry.

8.3. The structure bar

The structure bar is the view of the element containing the caret or the selection
and its ancestors up to the body element of the document that is visible just below

the and buttons in the main window of BlueGriffon.

Click on any element in the structurebar to select the corresponding element
entirely. Once that is done, you can place the caret right after or before the
selected element using the left and right arrow keys of your keyboard.
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You can also select the parent element, first child, next or previous sibling of the
current element container using the Edit > Select... menu. Please note the menu
entries in that menu have platform-dependant shortcuts.

But you can also right-click on any element in the structure bar for direct access
to the following features:

» set or reset the language of the element

+ set the writing direction (left-to-right or right-to-left) of the element,
something needed when you write a document mixing for instance a
western language and arabic or hebrew.

+ delete the element with all its contents

» delete the element but preserve all its contents

+ change the element (in that case, the element in the structure bar shows
a text field; just type the new tag and press return; use the Escape key to
cancel)

» copy the HTML markup for the elements and its contents to the clipboard

+ set the ARIA role for the element

What the structure bar shows for an element (ID, classes, role, language) can be
specified in the Preferences window, in the Documents panel.

8.4. Find and Replace

To find some text in the Wysiwyg view of a document use the Edit > Find menu
entry or hit ctrl-F (cmd-F on Mac OS X). It will make appear the Find&Replace
bars.

Replace All Replace Replace and Find Mext Replace by:

Previous = Mext B Case sensitive Find: (S [giil

Hit the escape key or click on the close button to hide that bar.

INEWIRVALZ! To find another occurrence of the same pattern, use the Edit > Find
Again menu entry or hit ctrl-G (cmd-G on Mac OS X).
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9. Insert content into the document

All text content in the document can be turned into a paragraph, a section header,
a preformatted paragraph, an address or a generic <div> element using the
format toolbar dropdown menu | paragraph : |. See the section

about the Formatting your content.
9.1. Insert a Table

To insert a table into the document at caret's position, use the Table > Insert >
Table menu or click on the Table toolbar button ~ | . That opens the following

dialog:

2x2

Just make the mouse pointer hover over a given cell and click to create a table. If
you want to create a table with greater dimensions, just reach the right or bottom
borders of the dialog and the table size will automatically expand. Hit the Escape
key or click anywhere outside of that dialog to cancel the insertion of a table.

new tables will always have a 100% width and a 1px wide border.
To add a new row or column to your table, you have several options:

» place the caret into a cell of that table and click on the small arrows that
appear on the cell's border

* right-click inside a table cell and use the Table Insert context menu

» place the caret into a cell of that table and click on the Table toolbar button
or use the Table > Table Properties menu or even the Table Properties
context menu. That will open the following dialog:
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Insert a Table

Table Properties

T Cells |
Size
Raws: 3|(5] Width: | 100% - |5
Columns: 3 |:| Height: - |:|
Rows in header: 0! |5| Conly header cells
Rows in footer: a |:| ] Only header cells
Layout
Border: 1 |:| pixels
Cell spacing: |:|| pixels =
Cell padding: |:|| pixels =
Apply | Cancel | | OK |

This dialog has two tabs, one dedicated to the whole table, and one dedicated to
cells, lines and rows. If you remove the border of the table, the Wiswyg view of
BlueGriffon will still show a red dashed outline for the table just to allow you to see
the table cells' limits.

Table Properties

[ Table [T

Selection

| celits) |

Changes will be applied before selection is changed.
4 Previous Next »

Size Content Alignment

Width: | 100% - |:| Horizontally: | - unspecified - =

Height: - |:| Vertically: | - unspecified - =
Style

— — —

Background color: '_\ /.' |_| Header(s} |_| Text is not wrapping

Apply | Cancel | | OK |

The second tab will allow you to style the currently selected cell, row or column.
Once that is done, you can move to the previous or next cell, row or column using

the and buttons.

To delete a table row or column, different options are possible:
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Tweak your table's layout using the mouse pointer

* place the caret into a table cell belonging to the row or column to delete
and click on the ® marker in the top border (to delete the column) or the
vertical border (to delete the row), or use the Table > Delete menu.

* right-click on the cell and use the Table Delete menu.

m deleting a table cell (the whole element, not only its contents)

is not recommended if you don't have strong HTML knowledge. The option
is present in the menus if you want to set yourself the rowspan or colspan
attributes to created expanded cells.

You can also joint adjacent cells selecting them and using the Table > Join Cells
menu or the Join Cells context menu. To select multiple cells to join them, place
the caret in the topmost-leftmost one and shift-click the others. Joined cells can
divided back into individual cells placing the caret inside them and using the Table
> Split Cell menu entry or Split Cell context menu.

9.2. Tweak your table's layout using the mouse pointer

If your table does not carry the CSS style border-collapse: collapse,
you can resize its rows and columns very easily. Just grab the border between
two lines or two columns and move it. Popups attached to your mouse pointer's

position will show the new sizes.

0o untitled - BlueGriffon

=3- [ | m SO e O @
Body Text 3ot rc BIU =SE=TE EEZTE EE 4
(no ID) o)l no cla ] (@] Variable width &1 | (no ARIA role) 2
£ unided J [ Stya proparts |

[ ssex T 47ex [ 230px Besesd[3sox 0 ssox I ssex |
o

| O3]

= T 160px | 117px
a 24.9% | 18.2%

Lopflspdfopll

Get add-ons! @ 005 o) [ g

9.3. Create a Table from a series of paragraphs
You can also create a table from a series of paragraphs containing columns of

data (think CSV) selecting these paragraphs and using the Table > Create Table
from Selection .
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Insert an Image

BlueGriffon creates a new table row for each paragraph in the selection.
Choose the character used to separate the selection into columns:

(= Comma
[_|5pace

gnore extra spaces
| Other Character:

Delete separator character

Cancel OK

9.4. Insert an Image

You can insert an image into your document through the Insert > Image menu
entry or the Image toolbar button o , opening the following dialog:

Select Image

Image location:

Make URL relative to page location

Title:
Alternate text:
Allow an empty alternate text

Long description URL: =}

Preview

Cancel OK

If your image is a remote resource (or a data URL), type its URL into the top text
field of that dialog; if it's local to your hard disk, click on the filepicker button

at the top-right of the window to select an image file. A preview of your image will
be displayed at the bottom of the window. If no preview is displayed, it means your
image file is corrupted or the remote resource is not reachable.

The Make URL relative to page location checkbox allows you to use in your
document an absolute or relative URL for your image.
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Insert an Anchor

it is of course impossible to create a relative URL for an image inserted
into a document that is not already saved: the document has no URL itself...

The title of the image represents advisory information for the element, such as
would be appropriate for a tooltip. It is optional.

The Alternate text is mandatory and is here to give information about the image
to visually impaired users using voice-enabled browsers, or to people using a text-
only browser. It's still possible to avoid providing that attribute checking the Allow
an empty alternate text checkbox but that practice is not recommended.

The longdesc attribute contains the URL for an external resource giving a longer
description of the image. Type a URL in the corresponding field or select a local
file.

the fate of the longdesc attribute is subject to complex discussions

in the standardization community. We have decided to maintain some User
Interface for this attribute whatever will be the standardization decision, first
because that attribute still exists in HTML4 and XHTML1, second because a lot
of people still rely on this very important Accessibility feature.

To edit the properties of an image already present into the document, double-click
on it or select it and use the Insert > Image menu entry or the toolbar button.

9.5. Insert an Anchor

Here, an anchor is the target of a link. Place the caret in your document and use
the Insert > Anchor menu entry or click on the Anchor toolbar button U . That
opens a very simple dialog where you can enter the name of the anchor:

Anchor's name:

Cancel OK

the name of an anchor must begin with a letter ([A-Za-z]) and may
be followed by any number of letters, digits ([0-9]), hyphens ("-"), underscores

("_"), colons (":"), and periods ("."). Whitespace is not allowed in the name of an
anchor.

Once the anchor is created, it will be shown as an anchor icon into the document:
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Insert a Hyperlink

9.2. LlCrea

To modify the anchor's name, double-click on it or select it and use the menu the
Insert > Anchor menu entry or click on the Anchor toolbar button again.

9.6. Insert a Hyperlink

To insert a hyperlink to a local or remote resource into the document, select some
content and use the Insert > Link menu entry or click on the Link toolbar button

Text

select

Target

Advisory Title

Title:

Window target
[ Open the link in:

(" cancel ) [ 0K

If you selected some content in the document, it will be visible (and read-only) in
the Text group. Otherwise, you must enter some textual contents for the link there.

The target of the link is either a URL you have to type or a local file you can select.
You can also enter an advisory title for your link, desktop browsers usually
showing that advisory title as a tooltip when the mouse pointer hovers over the

hyperlink.

Finally, you can set how you want the link to be activated (in the same window, in
a new one, ...).

the Window target settings should be used cautiously. If opening a link

in a new window can be seen as a desired behaviour by a Web page's author, it
can also be seen as an annoyance by the Web page's reader.
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Insert an Audio

To edit an existing link, double-click on it or use again the menu or the toolbar
button after selecting the link.

9.7. Insert an Audio

You can insert an audio restitution, with inline audio controls, using the Audio
toolbar button J‘J . That opens the following dialog:

Anchor's name:

Cancel OK

Type the URL for a remote audio file or select one from your local disks.
you can also select a video file, only the audio output will be done.

m the only officially supported formats are Vorbis, in Ogg containers,

as well as WAV format. This is not a restriction of BlueGriffon itself but is linked to
video codecs licenses. Google Chrome also supports H.264 but other browsers
may not be able to render that video format.

Once you have selected a valid audio file, new controls appear in the dialog:

Audio file location:

fUsers/glazou/Desktop/html5_Video_VPE.webm @
Make URL relative to page location
Preload: | None -

Show audio controls Play automatically Loop

Cancel OK

Once an audio restitution is inserted into the document, it is represented by the
following image inside content:

Jd
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Insert a Video

Double-click on it if you want to modify the properties of that audio restitution.
9.8. Insert a Video

Insertion of an video file is very similar to the insertion of an audio file. Use the
Video toolbar button & .

After entering a valid video resource, the dialog will appear as following:

QR o |

Video file location.

file:// {Users fglazou/Desktop/Pentagon_News_Sample.ogg =
[ Make URL relative to page location

Width: Height:

Preload: | None s

[ Show video contrals (| Play automatically (| Loop

| Use current frame as poster |

| Cancel | | OK |

You can play the video inline and select a given frame of that video as the poster
(the image that will appear before the user can play the video) clicking on the | Use
current frame as poster | button.

You can also switch to the Poster tab and select a poster from a remote resource
or local file, or save the current poster as a PNG file if it was selected directly from
the video in the Video tab.

To edit the properties of a video element already present in the document, double-
click on it or select it and use again the Video toolbar button.

9.9. Insert a Form

HTMLS5 form elements and sub-elements can be inserted using through the Form
toolbar button ™ ~ or through the Insert > Form menu.

First, create a new form. This will open the following dialog:
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Insert an horizontal bar

Name of the form:

URL:

Methed: GET POST

Autocompleted: on off

Encoding: -- unspecified --

Validation: Mo validation during form submission
Target: -

Character encodings:

Cancel Ok

This document is not a html/xhtml tutorial and editing html forms is difficult without
technical knowledge of the form attributes described in this dialog. Many free and
commercial html5 tutorials are available on the Web and in printed form.

Once your form container is created, it is visible in your document as an area
highlighted by a red dashed border. You can insert extra form sub-elements like
buttons or text areas, or non-form elements like paragraphs or headers, in that
form container according to your wishes.

To edit an already created form or form element, just double-click on it. Some form

elements require to turn mouse events inactive to make the elements editable; in
that case, use the toolbar button or the corresponding menu entry.

9.10. Insert an horizontal bar
Even if this element is far less used nowadays than it used to be in the early days

of the Web, some Web authors still like it a lot and BlueGriffon has the Insert >
Horizontal bar menu entry for that.
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Insert an arbitrary html element

Size
Width: P
Height: r :
Style

v/ shaded (3D
Alignment: Left Center Right

Color:

Cancel OK

You can specify the width, the height and the style of the <hr> element. Please
note that the corresponding styles will be carried directly by the element in a
style attribute.

Double-click on the bar itself or select it and use the menu entry to edit it.

9.11. Insert an arbitrary html element

To insert an arbitrary element from the list of all html5 elements, use the Insert >
HTML 5 Element menu entry. Please note that the insertion of an element using
that menu will delete the selection and replace it by the created element if the
selection in the document is not empty. To encapsulate the current selection into
a "stylistic" element, please see the section about the Format menu.

If the newly created element has an insertion dialog in BlueGriffon, that dialog will
automatically appear to let you edit the attributes of the element.

9.12. Insert HTML markup

You can also directly insert HTML markup (source code) at the caret's position
using the Insert > HTML markup menu entry.
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Paste content without Fomatting

Enter HTML markup or text below:

[ <p> |
| blah blah <strong=blah</strong> |
</p=

Cancel OK

Just type the HTML markup or paste it into the text area and hit the button. If
the selection is not restricted to a caret, the selection will be deleted to insert and
replaced by that markup.

9.13. Paste content without Fomatting
To paste Wysiwyg content without any formatting, for instance if you paste content
copied from a browser or an editor like MS Word, use the Edit > Paste without

Formatting menu entry or the Paste without Formatting context menu.

9.14. Insert a Table of Contents

BlueGriffon is able to automatically manage for you a table of contents. To create
a new Table of Contents in your document, select the Insert > Table of Contents
menu entry.
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Build table of contents from:

Tag: Class:

1>|

Level 1 | hl

L S

1>|

Level 2 | h2

L —

1b|

Level 3 | h3

1b|

Level 4 | h4

1>|

Level 5 | h5

{

Ak

Level 6 | hE

L —

E‘ Mumber all entries in the table of contents

"] Make the table of contents read-only

\.

( Cancel ) [ 0K

For each level of your table of contents, select the corresponding elements in
your document and optionally the attaches class. If for instance your document
has only two levels of contents and all level1 headers in your document are <h2
class="header"> while all level2 headers are <h3>, select h2 for Level 1 and
type header in the associated text area, select h3 for Level 2 and select -- for all
other levels.

You can automatically generate header numbers in your Table of Contents using
the corresponding checkbox in the dialog above. Please note these numbers
will only appear in your Table of Contents, not in your main content; you're still
responsible for that part.

the best way to add numbers to your section headers is to use CSS
generated content and counters. See the Miscellaneous section.

You can also make the Table read-only. If the corresponding checkbox remains
unchecked in the dialog above, you can still modify the generated Table of
Contents.

Hit the button to generate the Table.
To modify a previously created Table of Contents, select it (if it's read-only) or
place the caret anywhere inside it. Use the Insert > Table of Contents to reopen

the Table of Contents dialog.

You can also double-click on the comment starting the Table of Contents:
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2. ETable of Contents

(<l==mo2Toc N2 1 h3 2 hd 3 ...==2]
1. About BlueGriffon and this document
2. Table of Contents
3. Installing BlueGriffon
1. Windows
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10. Format your content

10.1. The span element

Encapsulating text inside span elements is one of the basic operations you
will often need. CSS (Cascading StyleSheets) allow to attach styles to elements,
not to arbitrary chunk of text.

Let's say you want for instance to color in red the word "HTML" in the text
"BlueGriffon is a Wysiwyg HTML editor". Then select that word in your content
and create a <span> element around it using the Format > Span menu entry.
INEWIRVARZ! You can also use the new dropdown button:

il <>~ I CE B

a (named anchor) P
A P

canvas
code

datalist

del

dfn

em
fieldset
i

ins

kbd
mark
meter

One click on the button in that dropdown button will encapsulate the current
selection into a span element. To encapsulate the selection in another inline
element, click on the arrow attached to the button to make the popup appear.

Once that is done, you can apply CSS styles (including the red color your originally
wanted) to that element using for instance the CSS Properties Panel.

Creating a span also allows you to give an ID and/or classes to a chunk of text.
10.2. The format dropdown menu

The format dropdown menu | Paragraph : | allows you to specify
the format of the current block of text. You can, using that dropdown, turn for
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instance the current paragraph into the a Section 1 Header or a preformatted
section (a <pre> element). The available options are the following ones:

* Body text (no block container, the text is directly a child of the parent block
element

» Paragraph (<p>)

* Heading 1to 6 (<h1>to <h6>)

* Address (<address>)

* Preformat (<pre>)

» Generic container (<div>)

10.3. Emphasis

To emphase a chunk of text, select it and use the emphasis toolbar button ! or
the corresponding Format > Emphasis menu entry.

An emphasis is usually rendered in italic font but you should not use that feature

to explicitly render some text in italics. An emphasis implies some sort of highlight
for the benefit of reader, not stylistic hints.

10.4. Strong emphasis

To strongly emphase a chunk of text, select it and use the emphasis toolbar
button ! or the corresponding Format > Stronger Emphasis menu entry.

An emphasis is usually rendered in bold font but you should not use that feature to

explicitly render some text in bold. An strong emphasis implies a strong highlight
for the benefit of reader, not stylistic hints.

10.5. Code

To specify a chunk of text is an excerpt from some machine-readable prose (in
general code or markup), you can select that text and use the code toolbar button
C or the corresponding Format > Code menu entry.

Code is usually rendered in monospace font but you should not use that feature

to explicitly render some text in monospace font. This element should be used in
relation to the semantics of its contents, not its stylistic hints.

10.6. Other inline stylistic elements

The Format menu also allows to create the following elements:

* Bold (<b>)
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Remove all text styles

* ltalic (<1i>)

* Underline (<u>)

+ Strikethrough (<s>)

» Superscript (<sup>)

* Subscript (<sub>)

» Fixed width (<tt>)

+ Citation (<cite>)
 Abbreviation (<abbr>)
» Acronym (<acronym>)
+ Sample output (<samp>)
» Variable (<var>)

The Bold, Italic and Underline elements can also be created and managed through
the corresponding toolbar buttons B | U . Please note these elements are

purely stylistic and do not carry any implied semantics.

10.7. Remove all text styles

Selecting text and using the Format > Remove all text styles menu entry or the
Remove all text styles contextual menu allows you to remove all inline elements
(see above) from the selected text.

10.8. Remove all links
Selecting text and using the Format > Remove all links menu entry or the

Remove all links contextual menu allows you to remove all links from the selected
text.

10.9. Ordered and unordered lists

To turn a given block element, for instance a paragraph into a list, place the caret

1. —

inside that paragraph and hit the ordered list #= or the unordered list button :=
. That will turn that block into the first list item of such a list.

When the CR key is hit at the end of a list item, it creates a new list item. Hit it a
second time to end the list.

To create a sublist item, hit the Tab key; to turn it back into an item one level above,
hit shift-Tab.

You can switch from an ordered list to an unordered list one at any time using the
toolbar buttons.
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Definition lists

To change the list properties of a set of list items, select them and use the Format
> List Properties menu entry.

List Marker
Type: | disc 'vl
Position:  inside m
Image: =

Make URL relative to the document

Value
# No start value specified

Start value: 1

Cancel | 0K |

To change the properties of the whole list, select it using the structure bar and use
the same menu entry.

The dialog above will create inline styles contained in style attributes.

m BlueGriffon has a known issue dealing with ordered and

unordered lists: nested lists should be contained in the list item preceding them
while they're currently created as a sibling of the previous list item... This is a
well-known problem in a lot of wysiwyg editors and all browsers will fortunately
render well that alternate model. To fix the html validity of your lists, use the
Tools > Markup Cleaner menu entry.

10.10. Definition lists

To create a definition list, type the first definition title for instance as a paragraph

and click on the Definition Term toolbar button = . Hitting the return key will

then create a Definition Description element after the Definition Term. Another hit
on return will add a new Term. To turn a Term into an extra Description for the

previous Term, use the Definition Description toolbar button = .

Two hits on the return key will make you leave the Definition List.
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Aligning a block

10.11. Aligning a block

You can very simply align a block using the four alignment toolbar buttons
= = . The first one will align the block's contents to the left, the second

will center it, the third will align it to the right and the last one (currently selected
in our screenshot) will justify the contents of the block. Please note the effect is
achieved applying CSS inline styles, i.e. styles contained in a style attribute on
the block element.

10.12. Indenting a block

You can also simply indent (or outdent) a block using the Indent (Outdent) toolbar
button = ( 4= ). Please note the effect is achieved applying CSS inline styles,

i.e. styles contained in a style attribute on the block element for all elements but
ordered and unordered lists. For lists, indentation creates nested lists.

10.13. Color and block background color

The two colorpicking buttons in the formatting toolbar . - | allow you to set:

+ a foreground color for the selection (no need to create a span first)
» a background color for the containing block
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Enrich your content

11. Enrich your content

There are several common ways to enrich your content:

* add attributes to elements

+ style it through CSS, and ID and classes

* add scripts

» specify the language and the writing direction of an element
» specify the role (ARIA) of an element

11.1. Assign an ID to an element

The easiest to assign an ID to a given element is to place the caret in that
element or select it through the structure bar and use the ID dropdown
(no 1D) ~ | in the Format toolbar.

Just type the ID you want to assign and press the Return key. If you click on the
arrow, a popup menu will show all the IDs used in all stylesheets applied to the
document.

To remove the ID assigned to an element, place the caret in the element and clear
the text field; you can alternatively click on the arrow and select the ID that is
already assigned.

If you try to assign to the element an ID already carried by another element in the
document, BlueGriffon will offer you to remove the ID assignment from the other
element or cancel the operation since an ID has to be unique in a document.

11.2. Assign a class to an element

Similarly, the easiest to assign a class to a given element is to place the caret
in that element or select it through the structure bar and use the class dropdown
(no class) + | in the Format toolbar.

Just type the class you want to assign and press the Return key. If you click on
the arrow, a popup menu will show all the classes used in all stylesheets applied
to the document.

To remove a class assigned to an element, place the caret in the element, remove
that class from the text field (an element can carry multiple classes); you can
alternatively click on the arrow and select the class. Classes already assigned
appear above the menu separator in the popup menu.

52/77



Floating Panels

11.3. Floating Panels

Floating panels are companion tools to BlueGriffon that live in their own window.
BlueGriffon 1.5 is released with the following four panels builtin:

» the DOM Explorer panel

+ the Style Properties panel
+ the Script Inspector panel
» the Stylesheets panel

They can be reached through the Panels menu, and sometimes a toolbar button.

You can align floating panels using the small button in its titlebar (not available on
all platforms) or the Panels > Align all panels menu entry. If a panel starts before
the start of the main window, it will be realigned before the main window; it will
be realigned after the end of the main window if it starts after it start. Two panels
intersecting in terms of horizontal position will be realigned at the same position
and will share the available vertical space:

Panels' positions are persistent and they will be preserved and restored across
sessions.

A new pin button is available that docks the panel into the main window.
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The DOM Explorer

Once a panel is docked, you can close it or restore it as a floating panel through
the Panels menu or using the context click menu on the panel's tab.

Panels are a bit different on Linux for technical reasons and the

two aforementioned buttons are not present in the panel's titlebar. Please use
the Panels menu instead.

11.4. The DOM Explorer

The DOM Explorer is a floating panel of BlueGriffon that allows you to browse the
elemental structure of a document and manipulate attributes and inline styles of
all elements.

Use the Panels > DOM Explorer menu entry or click on the corresponding button
in the main toolbar .ﬁ’ . It will open the following panel:
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The Stylesheets panel

[ Attributes | Inline Styles !

Name Value
class copyright

L/
You can navigate in the document tree using the upper part of that dialog. If you
change the selection or the caret's position in the main window of BlueGriffon,
the tree in the DOM Explorer panel will be automatically updated and the correct

element selected. Similarly, selection will be updated in the main window when
you select an element in the DOM Explorer.

The two tabs in the lower part of the panel allow to set/remove/modify attributes
on one hand and inline CSS styles on the other.

11.5. The Stylesheets panel

The stylesheets panel allows you to add CSS stylesheets, embedded or linked, to
your document. Use the Panels > Stylesheets menu entry.
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The Stylesheets panel

=, Stylesheets

URL Media
styles fmain.css

A

That panel allows you to add, delete, modify, move up or down in the list of
stylesheets a stylesheet embedded in the document or attached to the document.
Click on the |+ button to add a new stylesheet.

Type
(*) Embedded in the document () Linked to the document

Stylesheet is an alternate stylesheet

Href: &

Make URL relative to page location MNew file

Title:

Media

Ii Add a new mediumj

b | b |
I': Cancel ) I': OK )

p

The default choice is a stylesheet embedded into the document. Click on Linked
to the document to add an external stylesheet. In that case and your stylesheet
does not exist yet, you can create a blank file using the button.

To restrict your stylesheet to specific media types, use the (Add a new medium|
button. That will allow you to build media constraints based on CSS Media
Queries. Below, the user is about to add to the document a stylesheet valid for
handheld devices and screens not wider than 400 pixels:
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The Stylesheets panel

‘ Type
| @Embedded in the document I;:,'lLinI-:ed to the document

Stylesheet is an alternate stylesheet

Href: @

Make URL relative to page |location Mew file
Title:
Media
[ : || screen media | | Add constraint |
: Max. width of the viewport: |§|
[ ¢ || handheld media | | Add constraint |

| Add a new medium |

| Cancel |[ OK ] i

Using the wheel button in the first screenshot above, you can edit the properties
of the selected stylesheet or directly edit its contents.

editing directly the contents of a stylesheet is a feature restricted

to embedded stylesheets and stylesheets linked from your computer (in other
words, files reachable through a file:/// URL)

BlueGriffon - main.css

@ font-face {
font-family: "Candara";
src: url("../fonts/Candara.ttf") format("truetype");

émedia print {
img {
max-height: 300px;
width: auto;

}
}
> #docTitle {
}

body {
font-family: Arial, Helvetica, sans-serif;

}

hz {
page-break-before: always;
border-bottom-width: 1px;
border-bottom-style: =solid;
border-bottom=color: rgb(153, 153, 153);
counter-increment: levelZcounter;
counter-reset: level3counter;

h2:before {
content: counter(levelZcounter, decimal) ". "
}
h3 {
counter-increment: level3icounter;
counter-reset: leveldcounter; *
|3
3 1ale
[ Commit changes )
|

That window has the following features:

» contents are highlighted with respect to CSS grammar
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The Script Inspector panel

» you can click on a line to "fold" the corresponding CSS rule if that line
contains an opening curly brace "{". In the screenshot above, the style rule
having #docTitle as selector is folded.

+ click a second time on it to unfold it

* hit Cmd-L (on Mac) or Ctrl-L (on Windows and Linux) to reach a given line
number

* hit Cmd-F (on Mac) or Ctrl-F (on Windows and Linux) to find text

« INEWIRVALZ] hit Cmd-G (on Mac) or Ctrl-G (on Windows and Linux) to find
next occurrence of the pattern

+ hit the (Commit changes | button to save your changes

+ hit the close button of the window in its titlebar to discard your changes

Of course, committed changes are immediately applied to your document.
11.6. The Script Inspector panel

The Script Inspector panel allows you to add scripts, embedded or linked, to your
document. Use the Panels > Script Inspector menu entry.

. Script Inspector

g var cnnIsHomePage=true, cnniVPAdSection="edition.cnn.com ma
@ hitp://z. ednturner.com/enn/tmpl_a.. _homepage/368/ s fintthplib-min.js
@ Slcdn.optimizely.com/js/ 12872 754605

B if{html5Check){ Event.ocbserve|(window, load’,functioni){ 5(

+ |- =

The Script Inspector lists all scripts present in the document. A script listed in italic
font is a remote resource that is not directly editable by BlueGriffon.

Click on the button and select Add embedded script to add a new script
fully container in your document. In that case, a JavaSript editor will immediately
appear to let you edit your script. JavaScript syntax errors are visible in the gutter
and you can fold lines starting a block.
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The Style Properties panel

BlueGriffon - Script editor

test case 1

L

> const kPRODUCTS_ENUM = |
¥

var glist = null;
function Startup(]

{
gList = new Array()):
}

[ Commit changes )

e

In the view above, an object is folded starting at line 7 and there's is a syntax error
on line 15.

That window has the following features:

contents are highlighted with respect to JavaScript grammar

you can click on a line to "fold" the corresponding block if that line contains
an opening curly brace "{".

click a second time on it to unfold it

hit Cmd-L (on Mac) or Ctrl-L (on Windows and Linux) to reach a given line
number

hit Cmd-F (on Mac) or Ctrl-F (on Windows and Linux) to find text
INEWIRVALZ hit Cmd-G (on Mac) or Ctrl-G (on Windows and Linux) to find
next occurrence of the pattern

hit the (Commit changes | button to save your changes

hit the close button of the window in its titlebar to discard your changes

To link an external script to your document, click on the |+ button and select Add
external script .

11.7. The Style Properties panel

The Style Properties panel allows you to manipulate the CSS styles attached to
a given element or group of elements. It is a very powerful tool that hides almost
entirely the complexity of CSS and its Cascade. Whetever are the styles you want
to apply and wherever comes your document from, the Style Properties panel will
always find a way to perform the requested action.
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The Style Properties panel

To open the Style Properties panel, select Panels > Style Properties or click on

the corresponding toolbar button ul .

%, Style Properties

<img> ‘

Apply styles to:

this element only through its ID v

[Jwhen the painter hovers aver the element

The element currently edited is shown at the top of that panel, to let you make
sure you apply styles to the correct element.

Four main options are available for your styles:

1.

3.
4.

link your styles to the ID of the element. If the element has no ID, you'll be
prompted for one when you assign styles to your element. In practice, this
will create or edit a CSS rule based on a single ID selector. If you chose
the automatic CSS policy and assigned no ID here before a style change,
BlueGriffon will select a random ID for you.

link your styles to a class carried by the element. In that case, a dropdown
allows you to select a class or even enter it if the element has no class yet
or if you want to link the styles to a new class to be carried by the element.
If you chose the automatic CSS policy and assigned no class here before
a style change, BlueGriffon will select a random class for you.

link your styles to all elements of same element type.

store your styles into the style attribute carried by the element.

You can also, in the three first cases only, tell BlueGriffon your styles apply only
when the mouse pointer hovers over the element.

N\o)-Hl the Style Properties panel will modify all local (embedded or local

to the filesystem) stylesheets linked to the document to apply styles. If no
stylesheet is available, it will create a new embedded stylesheet. If no existing
CSS rule matching your change request exists in the local stylesheets,

60/77



General > Font Family

BlueGriffon will generate a new CSS rule in the last local stylesheet in document
traversal order. If you want to have all your styles saved into an external
stylesheet, make sure the last stylesheet available in your document is linked
(and local to the filesystem) and not embedded.

Thirteen different stylistic sections are available in the panel. Here are the
corresponding CSS properties:

font-family, font-size, line-height, font-weight, font-style, text-
decoration, text-transform, font-variant, text-align, vertical-

General align, direction, letter-spacing, word-spacing, word-wrap,
text-indent
color, background-color, background-image, background-
Colors repeat, background-attachment, background-position,
background-size, background-clip, background-origin
width, min-width, max-width, height, min-height, max-height,
Geometry

margins, paddings

display, visibility, float, clear, overflow, text-overflow,
position, z-index, left, right, top bottom

border-width, border-size, border-style for all four edges,

Position and Layout

Borders )
border-image
Shadows box-shadow, text-shadow
Lists list-style-type, list-style-position, list-style-image
. transform-origin, perspective-origin, transform-style,
Transformations L .
backface-visibility, transform, perspective
o transition-property, transition-delay, transition-duration,
Transitions I, . .
transition-timing-function
Flexibility box-align, box-direction, box-flex, box-ordinal-group, box-
pack
column-count, column-width, column-gap, column-rule-
Columns )
color, column-rule-style, column-rule-width
Tables table-layout, border-spacing, caption-side, empty-cells,

border-collapse
cursor, unicode-bidi, orphans, widows, page-break-before,
page-break-inside, page-break-after

Miscellaneous

You can close all sections but one or close all sections context-clicking on the
header of that section.

We are going to detail all CSS styles available here, this manual not being a CSS
tutorial, but you'll find below explanations for the most complex ones.

11.7.1. General > Font Family

When you add a font to the list of possible fonts for the element, you can check a
special checkbox to preview all fonts. This can take time the first time you use it.

61/77



General > Images

| -

# View fonts

Arial, Helvetica, sans-serif
| Times New Roman, Times, serif
Courier Mew, Courier, monocspa

Candara

| Al Bayan
American Typewriter

| Andale Mono
| Apple Braille

Apple Chancery
Apple LiGothic

11.7.2. General > Images

That item allows you to assign one or multiple (stacked) image and gradient
background(s) to an element.

Click on the button and select the type of background you want to add: linear
gradient, radial gradient, image.

Once a gradient or image background is added, you can change how it is
attached, repeated, positioned in the element's boxes, sized and placed:

Images: Linear gradient

Attachment: | fx ] Siza:

Repetition: - ] Fainting area:

Fosition: - ] Origin:
Radial gradient

Attachment: | v ] Siza:

Repetition: - ] Fainting area:

Position: hd ] Origin:

UL

To remove a background, click in the white area or its title and use the (-] button.
To edit an existing background, just click on its preview.
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General > Images

Gradients

m Starting with BlueGriffon 1.6, the application recognizes and

outputs the last proposed gradient syntax that differs from what previous
versions of BlueGriffon implemented.

When you add a gradient, the first thing you have to do is to define at least two
color stops for that gradient.

Preview [ Color stops ~ Angle Starting point

Length: P I:ll
Length: e I:ll

[_| Repeating

Cancel ' - OK

You can add and remove color stops using the (+] and (-] buttons. To select a color
stop, click in its right area (the one containing the length definition). To edit the
color of a color stop, click on the color itself to open a colorpicker.

To make a repeating gradient, use the checkbox on the left hand side of the dialog.

The angle tab lets you edit the angle of gradient:

Preview ' Color stops | Angle | Starting point '

[ Angle: - -53 @ degrees

[_] Repeating

Cancel y , 0K

Just turn the knob using your mouse or set directly the value in the textbox. You
can also use the spinbuttons. Unchecking the checkbox will make your gradient
use the CSS default value for the angle.
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General > Images

The Starting Point tab allows you to specify the starting point of your angle, using
a precise position or keywords like top/bottom/left/right/center and offsets:

Preview r Color stops ~ Angle | Starting point ] |

|_ Starting point: i ]
[ Horiz. offsat: - ]m [ vert. offsat: v ]m |

[_] Rapaating

i

Cancel 0K

Radial gradients also let you define the shape and size of the gradient:

Preview r Color stops | Shape and size | Angle Starting point 1

Shape: O Circular & Elliptic

. | = .
Size: | closest-side ... Iy ]

[_] Repaating

Cancel ) [ oK

Images

When an image background is added, the follow dialog appears:
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Geometry

Enter an image URL

i /Desktop/banner240x120.png [%

E Make URL relative to the document

Preview

It allows you to type a URL or select a local file, make the URL relative to the
document (if it's already saved) and preview the image. Click on OK when your
choice is made.

11.7.3. Geometry

By default, padding and margin settings apply to the four edges. A checkbox (one
for margins and one for paddings) allows to specify different values for all four
edges.

11.7.4. Borders > Sliced Image

That feature is complex and very powerful. It allows to slice an image into 9
different parts and use them to form the border of an element. After the selection

of the image you want to use, the Style Properties panel will show for instance the
following Ul:
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Transformations

& Use a sliced image as border

Image location

./../Desktop/border2 png &3

Grab the red lines and move them according to your wishes, or use the text fields
below the image to slice it.

A correct slicing of the image above applied as a border on a paragraph could for
instance give the following result:

11.7.5. Transformations

CSS3 2D and 3D Transformations are the new cool kid on the Web block.
They allow unprecedented special effects on the Web and will become without
any doubt one of the major features of CSS. This manual not being a CSS
Tutorial, we recommend you read such a tutorial on CSS3 2D and 3D Transforms
before manipulating the corresponding BlueGriffon Ul. If you already have a good
knowledge of CSS3 Transforms, you won't be surprised at all by what you can find
here. Only one kind of transformation, 3D Rotations, require Ul explanations:
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Transitions

3D Rotation

z K -D.444444444

¥: |0.0555555555

Axis: 3 3
X +/l x /l 7 0.7027283689
3 . » Mormalize

™ From scraen toward the user () From user toward the screen

in
Angle: * il l,r] degrees

To specify the axis of rotation, make your mouse pointer hover over the X/Y circle;
the corresponding position in the X/Z plan will be automatically computed from
normalized coordinates. By default, the Z value is positive, meaning the axis goes
from the screen toward the user. A checkbox allows to invert that and use negative
values for Z, from the user toward the screen.

You can also use the three text fields and optionally normalize the vector.

Use the knob or the corresponding text field to specify the rotation angle.
11.7.6. Transitions

The Style Properties panel offers full Ul for CSS 3 Transitions, including for their
timing functions.

To specify a transition, click on the button. You can specify you want one
property or all properties to transition. You can also specify you want no property
to transition to override different settings coming from other style rules. Let's
suppose below you want one CSS property to transition:

One property

Property:  width Dwration: 5.0:040 Ehl seconds
Function: | ease L] Delay: O.000 Ehl seconds
4+ | =

You can specify in that dialog the name of property, the length (in seconds) of
the transition, the initial delay (in seconds) before it starts and finally the timing
function. You can type your timing-function in the corresponding text field if you're
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SVG

an advanced CSS author, or you can click on the dropdown arrow to open the
following subdialog:

17 | Point 1:
E* E . | X: 10.25
fos T/ . [o099999
EL | | Point 2:
8 -||||i||||I| X |0.25

a 0.5 1 v |1

Input Percentage
linear ease-im  ease-out ease-in-out
I: Cancel ) E—H

You can select a pre-defined timing function, edit directly the two points
coordinates in their respective text fields or better, grab the two red dots and move
them to define your timing function using your mouse ! Once it's done, just click

the button.
11.8. SVG

BlueGriffon embeds (with permission) the popular SVG editor SVG Edit. To insert
SVG graphics inside your document at the caret's position, just click on the

corresponding toolbar button ﬁ? . This will open the following window:

SV Edit;

D@

©
&
2

e

NOEEmPONEE -] &

FITEERY TIEEE et e————r

u "_ - Fowered by 5¥G-edit v2.G-prefiphs
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Adding WebFonts to your document

Once your edits are done, click on the leftmost at the top of the window and
select Insert Image in BlueGriffon . Your SVG image will appear as is in the main
Wysiwyg view of BlueGriffon. To edit such an image, just double-click on it.

if your document is an HTML4 document, i.e. if your markup language

does not stand namespaces, BlueGriffon will automatically insert for you in the
document a chunk of JavaScript enabling SVG inside HTML4. Your image will
remain invisible without.

11.9. Adding WebFonts to your document

WebFonts only took off in 2009 but they are an old technology... WebFonts are
cool. WebFonts allow better and nicer web sites. WebFonts are cool but free fonts
are hard to find. So BlueGriffon has Ul to add fonts from the Google Font Directory
and the FontSquirrel repository to a document without having to deal with a single
line of code. If you want to enhance the browsing experience of your Web site,
you'll love WebFonts.

11.9.1. FontSquirrel

Select Insert > Web Fonts > FontSquirrel to open the FontSquirrel fonts manager
(the document must have been saved at least once in the past; if that's not the
case, save it, close it and reopen it):

FontSquirrel Fonts

Classifications Font list
Blackletter (13} Blokletters
Calligraphic (17) CabinSketch

Comic {21) Daniel
Dingbat (23) Desyrel
Display (B2) DJ Gross
Crunge (24) ElliotSix
Handdrawn (40} Eraser

Initials (3) Flux Architect
Monnsnared (22% Conal

Preview

Blue Griffon and Web Tonts

Cancel Add to document

Select a font family, and a font in that family. You can type some text to see a
preview of that text in that font. Click on the (Add to document] button to make
the font available through the Font dropdown in the Format toolbar and the Style
Properties panel.
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Google Font Directory

When you click on the button, BlueGriffon offers to either select the font from
the filesystem if you already installed it in the past or save the locally the package
downloaded from FontSquirrel:

FontSquirrel Fonts

Classiﬁ Is the selected font already locally available?
Blacklet

Calligra )
Comic | * Mo it's not, let me select a directory where to save the font package

A IYes it is, let me select the corresponding stylesheet.css file

Dingbal |
Display
Crunge
Handdrawn (40} D) Cross
Initials (3) ElliotSix
Mnnnsnaced (227 Fraser

Cancel | | oK |

Preview

BlueGriffon and Web Fords

|  Cancel | Add to document

11.9.2. Google Font Directory

BlueGriffon also offers direct access to the fonts in the Google Font Directory
(GFD). Select the Insert > Web Fonts > Google Font Directory menu entry.

Family Variants Subsets

| Cancel | | OK [

This dialog will list all the fonts from GFD already installed in your document and
offers to add to or remove from that list. Click on the | +] button to add a new font.
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Google Font Directory

! Font family ‘

‘ [ Cardo s ] ‘

Preview

Cardo

Subset

|_| Latin Cyrillic Greek Khmer

WVariants
|| Regular Italic
Bold Bold-italic

| Cancel I[ 0K J

Select a font, select the font variants you want to include and hit the button.
Your font is now visible in the Font dropdown in the Format toolbar and the Style
Properties panel.
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The Source view

12. The Source view

To switch to the Source view of a document, click on the button just
below the editing viewport, use the View > Toggle view menu entry or use the
corresponding shortcut (F8 function key).

BlueGriffon User's Manual

b

at the top of the window
n BlueGriffon</span>.
£E

lass="button">Source</span>

mixing

t (ID, classes, role, language)
in the Documents panel.</p>

o the Source view of a document, click on the <span class="button'>Source</span>
below the editing viewport:</p>

<p><br />

</p>

Get add-onst [£) 200% 52 &

The current line is highlighted in light blue. The position of the caret will match (as
far as it is possible) the position of the caret in the Wysiwyg view.

That window has the following features:

+ contents are highlighted with respect to HTML, CSS and JavaScript
grammar

* you can click on a line to "fold" an html element spanning over multiple
lines.

+ click a second time on it to unfold it

* hit Cmd-L (on Mac) or Ctrl-L (on Windows and Linux) to reach a given line
number

* hit Cmd-F (on Mac) or Ctrl-F (on Windows and Linux) to find text

The Source View will also mark in red in the line numbers' gutter the syntax error
it detects.

Remember you can select the default theme of the Source View in the
Preferences? You can also set the theme of the current Source View only using
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The Source view

the View > Source View > Theme menu. Your choice will be applied only to the
current Source view and has no effect on your default choice.

Each document tab in BlueGriffon has its own Source view, a big difference with
BlueGriffon's ancestors Mozilla Composer and Nvu.
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13. Miscellaneous

13.1. Markup Cleaner

We have an extra tool in BlueGriffon here to let you clean up the markup
BlueGriffon generates. Select Tools > Markup Cleaner to launch it.

E] Fix nested lists

| Action Report

|

|
¥ Remove trailing <brx

¥ Remove empty blocks

¥ Remove alignment on empty table cells

Cancel | Clean up |

It can perform four different actions on the whole document:

1. fix nested lists (see the warning in Ordered and Unordered Lists section).
2. remove useless <br> elements at the end of blocks or table cells.

3. delete empty blocks from the document.

4. remove useless alignment settings on empty table cells.

Check or uncheck the checkboxes depending on your wishes. Clicking on Clean
up will launch the cleanup process. In front of each choice will show the
corresponding number of changes after completion of the cleanup process.

13.2. Special Characters

If Mac OS X has a wonderful system-wide application for Special Characters
(reachable through cmd-alt-T), Windows and Linux don't have one. Well, some
Windows do but charmap.exe is not always available. So we added such a
dialog for Windows and Linux users, and you can reach it using the Edit > Special
Characters menu entry:
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Insert special characters
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Unicode:
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13.3. Spell checking

If you enabled the spellchecker in the Preferences window and have a dictionary
for the language you're currently editing, all errors detected by the spellchecker
will appear underlined in red. You can see the spellchecker's suggestions by a
right-click on the misspelled word and using the Spellcheck menu entry.

To change the active dictionary, use the context menu again and the Dictionary
menu entry. Free dictionaries for BlueGriffon are available from our web site.

To run the spellchecker against the whole document in one single operation, use

the Edit > Spellcheck menu entry:
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http://www.bluegriffon.com/index.php?pages/Dictionaries

Community

Check Spelling
Misspelled word:  BlueGriffon Recheck Page
Replace with: Blue Griffon Check Word
Suggestions:
Blue Griffon Replace lgnore
Blue-griffon
Griffon Replace All lgnore All
Personal Dictionary:

Add Word Edit...
Language:
English/United States H Close

13.4. Community

You will find under the Help menu direct links to the BlueGriffon community:

+ follow our announcements on Twitter under @BlueGriffonApp

* you can reach our Google Group for chat under Tools > User's
Community or directly through this link.

+ to submit bugs or request for enhancements, please use Tools > Bugs
and Suggestions or go to our Bugzilla directly through this link.
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Changes from version 1.6.2

14. Changes from version 1.6.2

* bustage in Image Insertion dialog

* minor fixes in stylesheet and script code editors

* Find was horked in wysiwyg view

» disable and re-enable spellchecking when switching back to wysiwyg:
n=490

» search in stylesheet editor horked; b=520

« fix for endless replaceAll; b=523

« Title bar not updated when last tab is closed; b=531

+ find next shortcut: b=549

» can't use nobr: b=546

» cannot underline a standalone a text node; b=551

* move to new build system and new langpack organization

* links from clipboard in insertLinks; b=547

* better detection of xhtml5

» adhere better to flexbox spec

* insertion dialogs can now be called from source view

* inline encapsulation button
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